Documentation for recent versions (Linutop OS V4) is available on http://doc.linutop.com


Talk:Distro/Debian etch install on Linutop

From LinutopWiki

I'm in the process of installing Debain Lenny on my Linutop 2 using a 4Gb USB drive. Which disk partitioning method should I choose if I don't want to fry the Linutop splash screen and PXE booting capabilities, or perhaps there's no danger of this? I'm not sure.

Guided - use the largest continuous free space
Guided - use entire disk

Thanks in advance.

sebyte 09:00, 10 February 2010 (CET)

The initial splash and PXE config are handled by the BIOS, before the OS, so there's no risk at all to erase them (this is not stored on disk).

gpocentek

Thanks for confirming this. I just wanted to be sure. On an unrelated note, can the Linutop 3 be attached to a monitor with a monitor bracket? It doesn't look like it from the photos.

sebyte 09:19, 10 February 2010 (CET)

Indeed, the Linutop 3 is to large to be attached to the back of a monitor...

gpocentek

Thanks again.

Another issue has come up since succesfully installing Debian Lenny. Not having expanded the RAM beyond 1GB I don't have enough disk space to install xfce4 (presumably because I'm using a standard ext3 filesystem rather than the compressed file system(?) LinutopOS uses. This isn't a problem as I only want to use the machine to ssh in to remote boxes, but I do need a higher console resolution than the default 848x480, especially considering that mine is a 22 inch monitor (NEC LCD22WV). I've tried passing various boot parameters (vga=791 and vga=794) for resolutions which my monitor definitely supports (1024x768 and 1280x1024) via grub, but without success, i.e., the console resolution stubbornly remains at 848x480. Any tips/suggestions as to how to solve this issue much appreciated.

Update: There is enough room to install xfce4 after all! I forgot to run 'apt-get clean' after initial installation of the system. Console resolution is thus no longer an issue.

sebyte 14:21, 10 February 2010 (CET)

I've installed xfce4 but now I'm having real trouble configuring the X server, or rather, the auto-detection process is failing. Any chance you could send me the /etc/X11/xorg.conf file that you ship with the LinutopOS, as that worked perfectly before.

Could you send me a mail at 'gpocentek AT linutop.com' sa I can send you the file? Dialogs using the wiki are not easy. Thanks